import re
regex = re.compile(r"(\d+x)|.", flags=re.MULTILINE)
test_str = "u2x4m5x7"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)