import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?<target>[A-Z]{3}[0-9]{3})\\/product.lc";
final String string = "https://www.lanecrawford.com.hk/product/lane-crawford-vintage-accessories/vintage-chanel-flower-butterfly-scarf/_/BWG395/product.lc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}