$re = '/\/(?<target>[A-Z]{3}[0-9]{3})\/product.lc/m';
$str = 'https://www.lanecrawford.com.hk/product/lane-crawford-vintage-accessories/vintage-chanel-flower-butterfly-scarf/_/BWG395/product.lc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);