// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(?<target>[A-Z]{3}[0-9]{3})\/product.lc").unwrap();
let string = "https://www.lanecrawford.com.hk/product/lane-crawford-vintage-accessories/vintage-chanel-flower-butterfly-scarf/_/BWG395/product.lc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}