package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+|00)(3[0-689]|[0-24-9]\d)\d+$`)
var str = `+34999
0037999
0085999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}