$re = '/^(\+|00)(3[0-689]|[0-24-9]\d)\d+$/m';
$str = '+34999
0037999
0085999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);