const regex = /^(\+|00)(3[0-689]|[0-24-9]\d)\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+|00)(3[0-689]|[0-24-9]\\d)\\d+$', 'gm')
const str = `+34999
0037999
0085999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}