using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"input.*?name=(?'name'[^ ]+)";
string input = @"<input name=dir value="">"">
<input value="">"" name=dir >";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}