re = /input.*?name=(?'name'[^ ]+)/m
str = '<input name=dir value=">">
<input value=">" name=dir >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end