const regex = /^@@ -[1-9]+,[1-9]+ \+[1-9]+,[1-9]+ @@$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^@@ -[1-9]+,[1-9]+ \\+[1-9]+,[1-9]+ @@$', 'gm')
const str = `Snapshot Diff:
- <Component test=\\\\"say\\\\" />
+ <Component test=\\\\"my name\\\\" />
SHOULD MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@
- say
+ my name
@@ -32,1 +32,1 @@
- say
+ my name
SHOULD NOT MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@a
- say
+ my name
@@ 32,1 +32,1 @@
- say
+ my name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}