// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^@@ -[1-9]+,[1-9]+ \+[1-9]+,[1-9]+ @@$").unwrap();
let string = "Snapshot Diff:
- <Component test=\\\\\"say\\\\\" />
+ <Component test=\\\\\"my name\\\\\" />
SHOULD MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@
- say
+ my name
@@ -32,1 +32,1 @@
- say
+ my name
SHOULD NOT MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@a
- say
+ my name
@@ 32,1 +32,1 @@
- say
+ my name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}