$re = '/^@@ -[1-9]+,[1-9]+ \+[1-9]+,[1-9]+ @@$/m';
$str = 'Snapshot Diff:
- <Component test=\\\\"say\\\\" />
+ <Component test=\\\\"my name\\\\" />
SHOULD MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@
- say
+ my name
@@ -32,1 +32,1 @@
- say
+ my name
SHOULD NOT MATCH
@@ -6,1 +6,1 @@
- say
+ my name
@@ -9,1 +9,1 @@a
- say
+ my name
@@ 32,1 +32,1 @@
- say
+ my name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);