using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\\.|[^|\\]+)+";
string input = @"|123|create|item|1497359166334|Football|Some League|\|Team\| vs \|Team\||1497359216693|";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}