re = /(?:\\.|[^|\\]+)+/m
str = '|123|create|item|1497359166334|Football|Some League|\\|Team\\| vs \\|Team\\||1497359216693|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end