$re = '/_[^_]+(\.[^_]+)$/m';
$str = 'File_with_nr1_EN.txt
File_has_NR_3_ZHHK.txt
File_yy_nr_2_DE.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);