// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_[^_]+(\.[^_]+)$").unwrap();
let string = "File_with_nr1_EN.txt
File_has_NR_3_ZHHK.txt
File_yy_nr_2_DE.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}