re = /_[^_]+(\.[^_]+)$/m
str = 'File_with_nr1_EN.txt
File_has_NR_3_ZHHK.txt
File_yy_nr_2_DE.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end