import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d]{3}-[\\d]{3}-[\\d]{4}$";
final String string = "12333-\n"
+ "1ee-\n"
+ "1333333-\n"
+ "121-121-1212\n"
+ "1444-444-4444\n"
+ "12-12-1122\n"
+ "sd-sd-ssss\n"
+ "121-212-22222\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}