re = /^[\d]{3}-[\d]{3}-[\d]{4}$/m
str = '12333-
1ee-
1333333-
121-121-1212
1444-444-4444
12-12-1122
sd-sd-ssss
121-212-22222
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end