import re
regex = re.compile(r"^[\d]{3}-[\d]{3}-[\d]{4}$", flags=re.MULTILINE)
test_str = ("12333-\n"
"1ee-\n"
"1333333-\n"
"121-121-1212\n"
"1444-444-4444\n"
"12-12-1122\n"
"sd-sd-ssss\n"
"121-212-22222\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")