package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<DateTime>[^,]*),(?<username>[^,]*),(?<Action>[^,]*),(?<Entity>[^,]*)`)
var str = `2022-11-21 15:44:13,ea186520,CREATED,USERSESSIONLOG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}