$re = '/^(?<DateTime>[^,]*),(?<username>[^,]*),(?<Action>[^,]*),(?<Entity>[^,]*)/m';
$str = '2022-11-21 15:44:13,ea186520,CREATED,USERSESSIONLOG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);