import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?(href=\\x22.*?\\x22).*?>";
final String string = "<p>just a bunch of text here<a data-sv-linklookup-id=\"https://www.somesite.com/somevalue/?i=632738&ver=html5\" data-sv-linklookup-type=\"plugins_nav_external_link\" href=\"https://www.somesite.com/somevalue/?i=632738&ver=html5\" target=\"_blank\">view it online</a> or request it through our<a data-sv-linklookup-id=\"5a8dad3e2f124e053ecfe720\" data-sv-linklookup-type=\"plugins_nav_navitem_primary_main\" href=\"https://www.somesite.com/plan-your-trip/free-visitor-guide/\" target=\"_self\" title=\"some title\">online form</a>. a lot more text here<a data-sv-linklookup-id=\"5a8dad402f124e053ecfebd2\" data-sv-linklookup-type=\"plugins_nav_navitem_primary_main\" href=\"https://www.somesite.com/\" target=\"_self\" title=\"some title\">some more text</a></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}