// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a.*?(href=\x22.*?\x22).*?>").unwrap();
let string = "<p>just a bunch of text here<a data-sv-linklookup-id=\"https://www.somesite.com/somevalue/?i=632738&ver=html5\" data-sv-linklookup-type=\"plugins_nav_external_link\" href=\"https://www.somesite.com/somevalue/?i=632738&ver=html5\" target=\"_blank\">view it online</a> or request it through our<a data-sv-linklookup-id=\"5a8dad3e2f124e053ecfe720\" data-sv-linklookup-type=\"plugins_nav_navitem_primary_main\" href=\"https://www.somesite.com/plan-your-trip/free-visitor-guide/\" target=\"_self\" title=\"some title\">online form</a>. a lot more text here<a data-sv-linklookup-id=\"5a8dad402f124e053ecfebd2\" data-sv-linklookup-type=\"plugins_nav_navitem_primary_main\" href=\"https://www.somesite.com/\" target=\"_self\" title=\"some title\">some more text</a></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}