import Foundation
let pattern = #"<a.*?(href=\x22.*?\x22).*?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p>just a bunch of text here<a data-sv-linklookup-id="https://www.somesite.com/somevalue/?i=632738&ver=html5" data-sv-linklookup-type="plugins_nav_external_link" href="https://www.somesite.com/somevalue/?i=632738&ver=html5" target="_blank">view it online</a> or request it through our<a data-sv-linklookup-id="5a8dad3e2f124e053ecfe720" data-sv-linklookup-type="plugins_nav_navitem_primary_main" href="https://www.somesite.com/plan-your-trip/free-visitor-guide/" target="_self" title="some title">online form</a>. a lot more text here<a data-sv-linklookup-id="5a8dad402f124e053ecfebd2" data-sv-linklookup-type="plugins_nav_navitem_primary_main" href="https://www.somesite.com/" target="_self" title="some title">some more text</a></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)