package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(?:\.[0-9]+)?$`)
var str = `//valid
10.25
100
10.234455
5
//invalid
10,20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}