re = /^[0-9]+(?:\.[0-9]+)?$/m
str = '//valid
10.25
100
10.234455
5
//invalid
10,20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end