$re = '/^[0-9]+(?:\.[0-9]+)?$/m';
$str = '//valid
10.25
100
10.234455
5
//invalid
10,20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);