using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<sign>[+-])?\d+(?:\.?\d+)?(?<percent>%)?$";
string input = @"50
-50
+50
50%
+50%
-50%
50.50.50
+-50%
-50.%
4.%
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}