import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<sign>[+-])?\\d+(?:\\.?\\d+)?(?<percent>%)?$";
final String string = "50\n"
+ "-50\n"
+ "+50\n"
+ "50%\n"
+ "+50%\n"
+ "-50%\n"
+ "50.50.50\n"
+ "+-50%\n"
+ "-50.%\n"
+ "4.%\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}