const regex = /^([1-9]|1[012]):(0[0-9]|[1-5][0-9])\s?(am|AM|pm|PM)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|1[012]):(0[0-9]|[1-5][0-9])\\s?(am|AM|pm|PM)$', 'gm')
const str = `1:00am
10:00am
10:00pm
12:54am
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}