re = /^([1-9]|1[012]):(0[0-9]|[1-5][0-9])\s?(am|AM|pm|PM)$/m
str = '1:00am
10:00am
10:00pm
12:54am
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end