import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[\\n;](?:[\\t ]*(?:\\w+ )?)?)export(?:(?:\\s+(?<type>type)\\s*)|\\s*)(?<exports>\\{[\\w\\t\\n\\r \"$'*,./\\{\\}-]+?\\})(?=;?[\\t\\n;]*?(?!(?:\\n*\\/\\/)|(?:\\n*\\/\\*)|(?:\\s*from.*?)))";
final String string = "export { name1, /* */ nameN };\n"
+ "export { variable1 as name1, variable2 as name2, /* */ nameN };\n"
+ "export { variable1 as \"string name\" };\n"
+ "export { name1 as default /*, */ };\n"
+ "export type { CompilerOptionsJson as default };\n"
+ "export { default }\n"
+ "export { \n"
+ " DEFAULTS,\n"
+ " plugin as default,\n"
+ " type Options\n"
+ "}\n"
+ "export type { Config, Result }\n"
+ "export type { default as Options }\n\n"
+ "export { default } from './make'\n"
+ "export { \n"
+ " DEFAULTS,\n"
+ " plugin as default,\n"
+ " type Options\n"
+ "} from './plugin'\n"
+ "export type { Config, Result } from './interfaces'\n"
+ "export type { default as Options } from './options'\n\n"
+ "var g;export{name1};export{name1}\n"
+ "var g;export{name1}; export{name1}\n"
+ "export { name1, /* */ nameN }\n"
+ "export { import1 as \", import2 as name2, /* */ nameN }\n"
+ "export { default, /* */ }\n\n"
+ "declare module 'module-name' {\n"
+ " export { \n"
+ " DEFAULTS,\n"
+ " plugin as default,\n"
+ " type Options\n"
+ " }\n"
+ " export type { Config, Result }\n"
+ " export type { default as Options }\n"
+ "}\n\n"
+ "export { default } from './make'\n"
+ "export { \n"
+ " DEFAULTS,\n"
+ " plugin as default,\n"
+ " type Options\n"
+ "} from './plugin'\n"
+ "export type { Config, Result } from './interfaces'\n"
+ "export type { default as Options } from './options'\n\n\n"
+ "// export { default }\n\n"
+ "// export type { default as Statement }\n\n"
+ "/**\n"
+ " * @example\n"
+ " * export { default }\n"
+ " * export { Config, Result }\n"
+ " * export type { default as Options }\n"
+ " */\n\n"
+ "export { default, /* */ }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}