re = /(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export(?:(?:\s+(?<type>type)\s*)|\s*)(?<exports>{[\w\t\n\r "$'*,.\/{}-]+?})(?=;?[\t\n;]*?(?!(?:\n*\/\/)|(?:\n*\/\*)|(?:\s*from.*?)))/
str = 'export { name1, /* */ nameN };
export { variable1 as name1, variable2 as name2, /* */ nameN };
export { variable1 as "string name" };
export { name1 as default /*, */ };
export type { CompilerOptionsJson as default };
export { default }
export {
DEFAULTS,
plugin as default,
type Options
}
export type { Config, Result }
export type { default as Options }
export { default } from \'./make\'
export {
DEFAULTS,
plugin as default,
type Options
} from \'./plugin\'
export type { Config, Result } from \'./interfaces\'
export type { default as Options } from \'./options\'
var g;export{name1};export{name1}
var g;export{name1}; export{name1}
export { name1, /* */ nameN }
export { import1 as ", import2 as name2, /* */ nameN }
export { default, /* */ }
declare module \'module-name\' {
export {
DEFAULTS,
plugin as default,
type Options
}
export type { Config, Result }
export type { default as Options }
}
export { default } from \'./make\'
export {
DEFAULTS,
plugin as default,
type Options
} from \'./plugin\'
export type { Config, Result } from \'./interfaces\'
export type { default as Options } from \'./options\'
// export { default }
// export type { default as Statement }
/**
* @example
* export { default }
* export { Config, Result }
* export type { default as Options }
*/
export { default, /* */ }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end