# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export(?:(?:\s+(?<type>type)\s*)|\s*)(?<exports>{[\w\t\n\r \"$'*,./{}-]+?})(?=;?[\t\n;]*?(?!(?:\n*\/\/)|(?:\n*\/\*)|(?:\s*from.*?)))"
test_str = ("export { name1, /* */ nameN };\n"
"export { variable1 as name1, variable2 as name2, /* */ nameN };\n"
"export { variable1 as \"string name\" };\n"
"export { name1 as default /*, */ };\n"
"export type { CompilerOptionsJson as default };\n"
"export { default }\n"
"export { \n"
" DEFAULTS,\n"
" plugin as default,\n"
" type Options\n"
"}\n"
"export type { Config, Result }\n"
"export type { default as Options }\n\n"
"export { default } from './make'\n"
"export { \n"
" DEFAULTS,\n"
" plugin as default,\n"
" type Options\n"
"} from './plugin'\n"
"export type { Config, Result } from './interfaces'\n"
"export type { default as Options } from './options'\n\n"
"var g;export{name1};export{name1}\n"
"var g;export{name1}; export{name1}\n"
"export { name1, /* */ nameN }\n"
"export { import1 as \", import2 as name2, /* */ nameN }\n"
"export { default, /* */ }\n\n"
"declare module 'module-name' {\n"
" export { \n"
" DEFAULTS,\n"
" plugin as default,\n"
" type Options\n"
" }\n"
" export type { Config, Result }\n"
" export type { default as Options }\n"
"}\n\n"
"export { default } from './make'\n"
"export { \n"
" DEFAULTS,\n"
" plugin as default,\n"
" type Options\n"
"} from './plugin'\n"
"export type { Config, Result } from './interfaces'\n"
"export type { default as Options } from './options'\n\n\n"
"// export { default }\n\n"
"// export type { default as Statement }\n\n"
"/**\n"
" * @example\n"
" * export { default }\n"
" * export { Config, Result }\n"
" * export type { default as Options }\n"
" */\n\n"
"export { default, /* */ }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.