#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!nightly)((?<compatibility>\w*-?)?)(?<major>\d+)(\.(?<minor>\d+)(\.(?<patch>\d+)([\.-]?(?<build>.*)))?)?(?!nightly|developement|develop)$"
Local $sString = "100.200.300" & @CRLF & _
"100.200.300.7068-ls170" & @CRLF & _
"v100.200.300-ls213" & @CRLF & _
"version-100.200.300" & @CRLF & _
"version-100.200.300-ls180" & @CRLF & _
"version-100.200.300.11111" & @CRLF & _
"100.200.300.7068-ls170" & @CRLF & _
"nigthly-100.200.300" & @CRLF & _
"nightly-100.200.300.3604-ls587" & @CRLF & _
"100.200.300-development" & @CRLF & _
"100.200.300-develop" & @CRLF & _
"100.200.300-nigthly" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")