re = /^(?!nightly)((?<compatibility>\w*-?)?)(?<major>\d+)(\.(?<minor>\d+)(\.(?<patch>\d+)([\.-]?(?<build>.*)))?)?(?!nightly|developement|develop)$/m
str = '100.200.300
100.200.300.7068-ls170
v100.200.300-ls213
version-100.200.300
version-100.200.300-ls180
version-100.200.300.11111
100.200.300.7068-ls170
nigthly-100.200.300
nightly-100.200.300.3604-ls587
100.200.300-development
100.200.300-develop
100.200.300-nigthly
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end