import re
regex = re.compile(r"^(?!nightly)((?<compatibility>\w*-?)?)(?<major>\d+)(\.(?<minor>\d+)(\.(?<patch>\d+)([\.-]?(?<build>.*)))?)?(?!nightly|developement|develop)$", flags=re.MULTILINE)
test_str = ("100.200.300\n"
"100.200.300.7068-ls170\n"
"v100.200.300-ls213\n"
"version-100.200.300\n"
"version-100.200.300-ls180\n"
"version-100.200.300.11111\n"
"100.200.300.7068-ls170\n"
"nigthly-100.200.300\n"
"nightly-100.200.300.3604-ls587\n"
"100.200.300-development\n"
"100.200.300-develop\n"
"100.200.300-nigthly\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")