const regex = /(?<=\().+?(?=\))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\().+?(?=\\))', 'mg')
const str = `x^(3*x+1) + (cos x)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);