use strict;
my $str = 'x^(3*x+1) + (cos x)';
my $regex = qr/(?<=\().+?(?=\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";