#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{[^}{]*?"content"\s*:[^}{,]*?imgur\.com[^}{,]*?,[^}{]*?"from"\s*:[^}{,]*?ken_8520[^}{,]*?,[^}{]*?}"
Local $sString = " {"id": "1508640338717"," & @CRLF & _
" "displayName": null," & @CRLF & _
" "originalarrivaltime": "2017-10-25T14:08:57.128Z"," & @CRLF & _
" "messagetype": "RichText"," & @CRLF & _
" "version": 1508640338717," & @CRLF & _
" "content": "<a href=\"https://i.imgur.com/RTzSZiY.jpeg\">https://i.imgur.com/RTzSZiY.jpeg</a><e_m ts=\"1508940494\" ts_ms=\"1508940494784\" a=\"live:ken_8520\" t=\"61\"/>"," & @CRLF & _
" "conversationid": "8:markv"," & @CRLF & _
" "from": "8:live:ken_8520"," & @CRLF & _
" "properties": null," & @CRLF & _
" "amsreferences": null}," & @CRLF & _
"" & @CRLF & _
" {"id": "1508454757179"," & @CRLF & _
" "displayName": null," & @CRLF & _
" "originalarrivaltime": "2017-10-23T10:29:14.857Z"," & @CRLF & _
" "messagetype": "RichText"," & @CRLF & _
" "version": 1508454757179," & @CRLF & _
" "content": "<a href=\"https://i.imgur.com/hhSOfJu.jpeg\">https://i.imgur.com/hhSOfJu.jpeg</a><e_m ts=\"1508754504\" ts_ms=\"1508754504997\" a=\"live:ken_8520\" t=\"61\"/>"," & @CRLF & _
" "conversationid": "8:markv"," & @CRLF & _
" "from": "8:live:ken_8520"," & @CRLF & _
" "properties": null," & @CRLF & _
" "amsreferences": null}," & @CRLF & _
"" & @CRLF & _
" {"id": "1508405154918"," & @CRLF & _
" "displayName": null," & @CRLF & _
" "originalarrivaltime": "2017-10-14T18:19:13.66Z"," & @CRLF & _
" "messagetype": "RichText"," & @CRLF & _
" "version": 1508405154918," & @CRLF & _
" "content": "<a href=\"https://i.imgur.com/u1QFzVu.gif\">https://i.imgur.com/u1QFzVu.gif</a>"," & @CRLF & _
" "conversationid": "8:markv"," & @CRLF & _
" "from": "8:live:ken_8520"," & @CRLF & _
" "properties": null," & @CRLF & _
" "amsreferences": null}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")