$re = '/{[^}{]*?"content"\s*:[^}{,]*?imgur\.com[^}{,]*?,[^}{]*?"from"\s*:[^}{,]*?ken_8520[^}{,]*?,[^}{]*?}/';
$str = ' {"id": "1508640338717",
"displayName": null,
"originalarrivaltime": "2017-10-25T14:08:57.128Z",
"messagetype": "RichText",
"version": 1508640338717,
"content": "<a href=\\"https://i.imgur.com/RTzSZiY.jpeg\\">https://i.imgur.com/RTzSZiY.jpeg</a><e_m ts=\\"1508940494\\" ts_ms=\\"1508940494784\\" a=\\"live:ken_8520\\" t=\\"61\\"/>",
"conversationid": "8:markv",
"from": "8:live:ken_8520",
"properties": null,
"amsreferences": null},
{"id": "1508454757179",
"displayName": null,
"originalarrivaltime": "2017-10-23T10:29:14.857Z",
"messagetype": "RichText",
"version": 1508454757179,
"content": "<a href=\\"https://i.imgur.com/hhSOfJu.jpeg\\">https://i.imgur.com/hhSOfJu.jpeg</a><e_m ts=\\"1508754504\\" ts_ms=\\"1508754504997\\" a=\\"live:ken_8520\\" t=\\"61\\"/>",
"conversationid": "8:markv",
"from": "8:live:ken_8520",
"properties": null,
"amsreferences": null},
{"id": "1508405154918",
"displayName": null,
"originalarrivaltime": "2017-10-14T18:19:13.66Z",
"messagetype": "RichText",
"version": 1508405154918,
"content": "<a href=\\"https://i.imgur.com/u1QFzVu.gif\\">https://i.imgur.com/u1QFzVu.gif</a>",
"conversationid": "8:markv",
"from": "8:live:ken_8520",
"properties": null,
"amsreferences": null}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);