# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{[^}{]*?\"content\"\s*:[^}{,]*?imgur\.com[^}{,]*?,[^}{]*?\"from\"\s*:[^}{,]*?ken_8520[^}{,]*?,[^}{]*?}"
test_str = (" {\"id\": \"1508640338717\",\n"
" \"displayName\": null,\n"
" \"originalarrivaltime\": \"2017-10-25T14:08:57.128Z\",\n"
" \"messagetype\": \"RichText\",\n"
" \"version\": 1508640338717,\n"
" \"content\": \"<a href=\\\"https://i.imgur.com/RTzSZiY.jpeg\\\">https://i.imgur.com/RTzSZiY.jpeg</a><e_m ts=\\\"1508940494\\\" ts_ms=\\\"1508940494784\\\" a=\\\"live:ken_8520\\\" t=\\\"61\\\"/>\",\n"
" \"conversationid\": \"8:markv\",\n"
" \"from\": \"8:live:ken_8520\",\n"
" \"properties\": null,\n"
" \"amsreferences\": null},\n\n"
" {\"id\": \"1508454757179\",\n"
" \"displayName\": null,\n"
" \"originalarrivaltime\": \"2017-10-23T10:29:14.857Z\",\n"
" \"messagetype\": \"RichText\",\n"
" \"version\": 1508454757179,\n"
" \"content\": \"<a href=\\\"https://i.imgur.com/hhSOfJu.jpeg\\\">https://i.imgur.com/hhSOfJu.jpeg</a><e_m ts=\\\"1508754504\\\" ts_ms=\\\"1508754504997\\\" a=\\\"live:ken_8520\\\" t=\\\"61\\\"/>\",\n"
" \"conversationid\": \"8:markv\",\n"
" \"from\": \"8:live:ken_8520\",\n"
" \"properties\": null,\n"
" \"amsreferences\": null},\n\n"
" {\"id\": \"1508405154918\",\n"
" \"displayName\": null,\n"
" \"originalarrivaltime\": \"2017-10-14T18:19:13.66Z\",\n"
" \"messagetype\": \"RichText\",\n"
" \"version\": 1508405154918,\n"
" \"content\": \"<a href=\\\"https://i.imgur.com/u1QFzVu.gif\\\">https://i.imgur.com/u1QFzVu.gif</a>\",\n"
" \"conversationid\": \"8:markv\",\n"
" \"from\": \"8:live:ken_8520\",\n"
" \"properties\": null,\n"
" \"amsreferences\": null}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.