using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.$]";
string input = @"https://sun7-7.userapi.com/c853528/v853528199/cb6f5/RDcStuWYNbo.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}