$re = '/[.$]/m';
$str = 'https://sun7-7.userapi.com/c853528/v853528199/cb6f5/RDcStuWYNbo.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);