package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[.$]`)
var str = `https://sun7-7.userapi.com/c853528/v853528199/cb6f5/RDcStuWYNbo.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}