import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]\\d? *){1,12}";
final String string = "MESES\n\n"
+ "II III IV V VI VII VIII\n\n"
+ "SUBCONTRATACION*:\n\n"
+ "D SI\n\n"
+ "* Segun el Contrato Marco no existe autorizacion para ia Subcontratacion por lo quo 50\n"
+ "debera solicitar Ia autorizacion expresa del Cliente a Ia siguiente direccion do Correo\\nelectronico: (conflr.pedidos@bbva.com)\n\n"
+ "1 1 1 1 1 1 1 1 1\n\n"
+ "IX X XI XII\n\n\n\n\n"
+ ". LUGAR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}