import re
regex = re.compile(r"([1-9]\d? *){1,12}", flags=re.MULTILINE)
test_str = ("MESES\n\n"
"II III IV V VI VII VIII\n\n"
"SUBCONTRATACION*:\n\n"
"D SI\n\n"
"* Segun el Contrato Marco no existe autorizacion para ia Subcontratacion por lo quo 50\n"
"debera solicitar Ia autorizacion expresa del Cliente a Ia siguiente direccion do Correo\\nelectronico: (conflr.pedidos@bbva.com)\n\n"
"1 1 1 1 1 1 1 1 1\n\n"
"IX X XI XII\n\n\n\n\n"
". LUGAR")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")