re = /([1-9]\d? *){1,12}/m
str = 'MESES
II III IV V VI VII VIII
SUBCONTRATACION*:
D SI
* Segun el Contrato Marco no existe autorizacion para ia Subcontratacion por lo quo 50
debera solicitar Ia autorizacion expresa del Cliente a Ia siguiente direccion do Correo\\nelectronico: (conflr.pedidos@bbva.com)
1 1 1 1 1 1 1 1 1
IX X XI XII
. LUGAR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end