package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^\w]+)|([^\w]+$)`)
var str = `hello.
hello.world
,hello+world.;
...hello...world...
..hello12workd123.akfje.[]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}